怎么能让缉毒犬闻不到:麒麟短线王全套指标源码及使用说明

来源:百度文库 编辑:旧事旧闻 时间:2020/01/25 03:53:41

麒麟短线王全套指标源码及使用说明
一、使用说明

          操盘频率
     操盘频率是一个趋势类的指标,它由三条线条组成,分别是:操盘趋势,持仓线,空仓线组成,通常这个指标为我们明确指出了一个中期趋势的大方向,那么我们如何才能判断趋势及如何确定买卖点位呢?
一般我们把持仓线和空仓线均在上行状态的行情称为上升趋势,两条线往下的我们称为向下趋势,那么这里的买进信号是操盘趋势线在持仓线的上方运行了一个短期后由上向下跌破持仓线,但是其又没有跌破空仓线,随后股价再此向上穿越持仓线时,才是最佳的短线入场信号。
{操盘频率}
操盘趋势:MA(C,3),colorff00ff,linethick2;
持仓线:MA(H,21),coloryellow;
空仓线:MA(L,21),color00ff00;
           超级底部
      麒麟特色指标中我们增加了超级底部的特色指标,超级底部,顾名思义即可明白他是指向一个股票的底部区域的。我们所谓的超级底部,当他符合一定条件时,会有 一个红色的向下三角箭头会不断闪烁,提示您需要留心注意了。当目标股票中的超级底部线一旦走出红色的三角区时,就代表一个短期底部开始走出来,我们可以利 用搏股线来进行短线的搏杀。{超级底部指标}
VAR1:=MA(HHV(HIGH,485),17);
VAR2:=MA(HHV(HIGH,222),17);
VAR3:=MA(HHV(HIGH,96),17);
VAR4:=MA(LLV(LOW,485),17);
VAR5:=MA(LLV(LOW,222),17);
VAR6:=MA(LLV(LOW,96),17);
VAR7:=MA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)
/6,17);
VAR8:=MA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,17);
VAR9:=MA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,17);
VARA:=MA((VAR7*3+VAR8*2+VAR9)/6*1.738,17);
VARB:=IF(DATE<=1341231,VARA,VARA*DAY);
VARC:=LOW;
VARD:=REF(LOW,1);
VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),3,1)*100;
VARF:=MA(IF(CLOSE*1.35<=VARB,VARE*10,VARE/10),3);
VAR10:=LLV(LOW,30);
VAR11:=HHV(VARF,30);
VAR12:=1341231;
IF(DATE<=VAR12,MA(IF(LOW<=VAR10,(VARF+VAR11*2)/2,0),3),100000000); {超级底部}
Var3:=1;
Var4:=MA(CLOSE,5);
Var5:=MA(CLOSE,10);
Var6:=MA(CLOSE,30);
Var7:=MA(CLOSE,60);
Var8:=EMA(COST(85),7);
Var9:=EMA(COST(15),7);
VarA:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);
VarB:=Intpart(VarA*100)/100;
VarC:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);
VarD:=Intpart(VarC*100)/100;
VarE:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VarF:=Intpart(VarE*100)/100;
短线趋势:EMA(CLOSE,5)-EMA(CLOSE,10);
中线趋势:EMA(短线趋势,30);
Var10:=-100*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
Var11:=-100*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
Var12:=-100*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
Var13:=-100*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
Var14:=REF(中线趋势,1);
Var15:=中线趋势;
Var16:=Var15-Var14;
Var17:=REF(短线趋势,1);
Var18:=短线趋势;
Var19:=Var18-Var17;
Var1A:=OPEN;
Var1B:=CLOSE;
超级底部:If(Var1A<=Var4 AND Var1A<=Var5 AND Var1A<=Var6 AND Var1B>=Var4 AND Var1B>=VarF AND Var16>0 AND Var19>0 AND Var3=1,0.5,0);
短线指标:IF(CROSS(短线趋势,中线趋势) AND 短线趋势<0 AND 中线趋势<-0.2 AND Var11>45 AND Var16>0 AND Var3=1,1,0);             成本流量
         反应设定周期内市场庄家成本运行趋势的指标,成本流量主要表现该股在设定周期内持仓成本移动的方向,当短期的成本流量上穿中期的成本流量,说明短期内入场资金的持仓成本高于中期入场资金的持仓成本。表明短期内新资金大量入场推动了持仓成本的上升,投资者可视为买入的信号。
成本流量指标的另一个特殊的功能是可以监控一个股票的主流资金突然撤离的情况,当出现这种情形时,成本流量指标会大幅度地下行,在图表上显示一种“挖坑”的状态,投资者此时要引起高度的重视,一个主流资金在大幅退场的股票,其日后的发展潜力您说有多大呢。
          资金趋势
       资金趋势指标是提前反应市场资金流动趋势的指标。最有用的是资金趋势,0上持续运动一定有一波,在0下或0上不持续的就是弱势股是个很好的指标,大力推荐.
“资金趋势”指标,是以监测股票或指数在某一时间段内资金进出大小比例的一项专业分析指标。
当指标在设定分析周期内的数值大于0时,表明在此周期内以多方进场资金为主的买盘力量占据了主导地位。相反,当指标在设定分析周期内的数值小于0时,表明在此周期内以空方退场资金为主的卖盘力量占据主导地位。
如果指标在设定分析周期内的数据等于0时,表明多空双方资金的进出趋势达到了一个多空方的平衡点。{资金趋势}
a:=vol*close;
b:=sum(a,1)/sum(vol,1);
b1:=emA(b,17);
资金:(b-b1)*100/b,colorred;
强弱线:0,colorffcc66;
          持仓分界
         持仓分界分析目标股票里面持仓和空仓的临界点,当持仓分界数据为0的时候就代表目标股票要做方向选择,在方向不明朗的时候投资者最好处于观望,当数值 变为正数时就代表短期内目标股票所选择的方向开始向上,数值能连续增加则代表目标股票趋势越来越强;而反之则向下,投资在使用时最好结合持股线等特色指标 使用则更安全。
          搏杀持股线
       搏杀持股线实际上是一种集趋势、买卖与攻击动量于一体的能量线!它的每一次聚散离合,均准确地代表了一个趋势的开始与结束。
股票K线在经过一段时间下跌之后,处于搏杀生命线之下,只要市场上有某种强大的力量突然介入后,整个股价趋势自然也会随着这股新生力量的逐渐增强,而日益改变以前的运行方向,从而进入一种整理方式。这种整理的出现,往往会给这个本来已经非常低迷的市场带来一线生机。
       搏杀持股线就是多空分界线!
         搏杀持股线明显对股票的趋势有一种引导作用;而对股票的价格带有一种支撑与压制作用;一旦其表现出开始在趋势向下的势头之际,我们应当相应的卖出自己手中 所持有的股票,其表现的方式是:股价跌穿持股线,并引起了持股线的三线分开。相反,一旦发现趋势开始往上的时候,我们则可以相应的买进目标股所持有,其表 现的方式为:股价上穿持股线,持股线三线合一,同时引发持股线趋势开始往上。{麒麟均线(主图)}
amv0:=vol*(o+c)/2;
博杀生命线:sum(amv0,88)/sum(vol,88),colorff00ff,linethick2;
CG:ma(C,17),colorffcc66,linethick2;
FL:=hhv(CG,2);
博杀持股线:hhv(CG,2),color00ff00;
FS:CG-(FL-CG),coloryellow,linethick2;

            搏杀生命线
        搏杀生命线实际上就是股价强弱之势的分水岭!也常常代表了一种股价发展趋势。搏杀生命线同时对股票的趋势有一种引导作用;而对股票的价格带有一种非常大的支撑与压制作用;股价带量由下向上突破搏杀生命线,表明个股趋势开始走强的最佳体现!反之则由强开始走弱。
搏杀生命线向上转折的角度越大,则相应地说明庄家向上攻击的力度非常强、速度非常快、高度也非常高!反之我们也同样可以确认庄家向下攻击的情况。这样更增加了我们买卖目标股票的果断。
{搏杀持股}
CG:ma(C,17),colorffcc66;
FL:hhv(CG,2);
FS:if(CGSTICKLINE(close>=open,open,close,5,1),colorred;
STICKLINE(open>close,close,open,5,0 ),color00ff00;
STICKLINE(close>=open,close,HIGH,0.5 ,1 ),colorred;
STICKLINE(close>=open,open,low,0.5 ,1 ),colorred;
STICKLINE(open>close,close,low,0.5 ,0 ),color00ff00;
STICKLINE(open>close,open,HIGH,0.5 ,0 ),color00ff00;
{搏杀生命}
amv0:=vol*(o+c)/2;
BS:sum(amv0,88)/sum(vol,88),colorff00ff,linethick2;
STICKLINE(close>=open,open,close,5,1),colorred;
STICKLINE(open>close,close,open,5,0 ),color00ff00;
STICKLINE(close>=open,close,HIGH,0.5 ,1 ),colorred;
STICKLINE(close>=open,open,low,0.5 ,1 ),colorred;
STICKLINE(open>close,close,low,0.5 ,0 ),color00ff00;
STICKLINE(open>close,open,HIGH,0.5 ,0 ),color00ff00;

           底部构成
        底部构成指标是一个比较傻瓜的指标,平时一般不会有信号,一旦其满足某种条件后,指标线上会有黄颜色的柱状图形产生,在K线图上显示的非常醒目。如果目标 中的底部构成信号发出了指示,这个时候投资者可以对该股票进行密切关注,一旦股价有向上的攻击欲望,表现为股价向上穿越了十日均线,则未来的短线将会有一 个机会。
          
               短线动向
       及时扫描主力庄家异常操作行为的狙击指标,一旦出现巨幅波动,就是大资金频繁参与买卖的信号。短线动向指标可以在变化莫测的证券市场中,瞬间捕捉到主力资金活动的信号。
由于主力庄家往往在实际操作中总会刻意制造一些误导市场投资者的多头陷阱与空头陷阱,故此,我们在实战操作之中也就需要灵活地应用,最好能够配合“搏杀持 股”与“成本流量”等特色指标一起使用,以准确地判断出目前的主力庄家资金的主动性操作方向,从而回避某些主力庄家故意制造的误区。
                    短线快枪
        短线快枪指标是一个比较特殊的指标,平时的时候他的数值通常是0,但是一旦他的数值开始跳跃,那么他将预示未来股价将有一个或大或小的变动。这种信号是以不同形式的峰值表现出来。根据指标所形成的峰值的高低不同,我们可以判断:
指标峰谷的数值越小,说明主力进场的资金力度越小,其可靠性与有效性就十分的小。特别是后面的一个峰值超越了前面界面上所有一个峰值之时,表明主力进场的资金力度越来越大,其提供给投资者的买卖参考的准确性也将大为增强。
指标产生峰值的数值越大,说明主力进场的资金力度越大,但市场上的主力往往会在其大举进场后,引起了众多资金广泛关注。当指标产生峰谷的数值太大时,股价 短线波动幅度也将是十分巨大的。同时,可以给投资者带来短线巨大的利润与暂时性的损失(因为主力毕竟已进场,日后的拉升也只是时间的问题)所以,当指标产 生巨大的峰值的时候,是利润与风险并存的时候,如果投资者的短线操作经验不足与止损意识不强的话,切莫武断参与。
当指标产生峰谷的数值时(近半年内的最大值)投资者可密切关注,此时指标的准确度是十分高的,因为此时出现的峰谷,往往是在主力的主拉升段或初始派发阶段出现的,所以其准确性也将是十分高的。{短线快枪}
VAR1:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
快枪:EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10,COLORRED;
 
               短线强度
          短线强度是一个反映市场强弱的一个指标,其中分为三条线,浅灰色的是安全线,顾名思义,安全线就代表目标股票目前的安全或者风险,只有股票站在安全线上方 运行的时候才代表目标股票处于安全时期,反之则有风险!粗黄色的SK则代表短线趋动值,短线主导往上,真正牛股只有将短线趋动引导往上的时候才上涨升的开 始,SD代表中线趋动值,中线代表趋势,只有当某种趋势形成以后才会有整体个股趋势的上涨!如果发现SK慢慢偏离了代表股价的K线,则说明目标目前股票买 卖热,目标股票马上将面临回调或者短期头部的出现。
                   回吐支撑
          回吐支撑是一个通道性的指标,一般庄家机构每年的运作轨迹是在回吐支撑指标所筐定的范围之内。其分为清仓、出货、高抛、低吸、满仓五根指标线,顾名思义, 当股价下跌到低吸线时可以慢慢逢低吸纳,当股价达到满仓线时,这个时候可以大胆的考虑进场做多。这里要注意一点,由于政策性因素导致的股价非理性下跌情况 可能例外。
当股价经过逐波上涨,靠近高抛线一般投资者即可逢高离场了。而极端的庄家才可能把股价拉到出货线和清仓线。    { 回吐支撑} a:=ema(close,n); 清仓:a*1.382,colorgreen; 出货:a*1.191; 高抛:a*1.0168; 低吸:a*0.809,colorblue; 满仓:a*0.618; 指标解读: 其实这是个很简单的指标。属超买超卖类,收盘价的N日平滑均线向上或向下浮动M值而已,参数N 设定计算平滑均线的天数,一般为取费波南滋数列13,也可取14。参数M 取黄金分割率及其延伸数列其中可以看出清仓出货低系满仓都属于黄金分割率及其延伸数。高抛的数值不太清楚作者的思路,似乎并未有何含义。 其实这样的指标都源自于很普通的指标。如ENV指标,这一般的分析软件中都有,只要梢改参数就可以应用于实战。个人觉得以ENV指标应用费波南滋数列效果会更佳。 
               狙击量度线
          狙击量度线就是一个成交量类的分析指标,其主要监控一个股票的成交异动情况。狙击量度线为成交量设置了一个警示线,股市中股价的涨跌受到机构操纵的控制, 那么大鳄进入市场必然会溅起朵朵水花,当某日开始成交量突然开始连续放大,引得狙击量度线指标角度大幅上杨时,表明短期资金正在该股票上作连续性的攻击。
              买卖天机
          买卖天机是分析当天主动买卖盘,道出庄家操作股票的动机,当一只股票在某一段时间内,突然由前期的主动性买盘多变为主动卖盘多时,就表明在这段时间内有一部分资金开始往外出逃,股价正处于相对高位的时候,主动卖盘逐步增多,股价一旦跌搏杀持股线,则可能会形成短线头部。{买卖天机}
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:vol,pointdot;
主动买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE主动卖盘:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSEstickline(VOL>0,vol,0,4,1),colorwhite;
stickline(主动买盘>0,0,主动买盘,4,0),colorred;
stickline(主动卖盘<0,0,主动卖盘,4,0),color00ff00;

               卖空专家
          卖空专家是一个傻瓜形指标,当他的买进条件符合时,其会发生向上的数值跳跃信号,而一旦符合某种条件,他会以回档、警戒、风险的形式表现出来,当目标股票中该指标产生了向下的信号。代表了该股的短线行情的终结。
              麒麟趋势
         在麒麟短线王中,麒麟趋势指标是一个反映个股对比大盘的指标,我们知道,个股如果有短线资金大力推进的时候,其走势往往会独立与大盘,领先于大盘,在麒麟趋势中,表现个股趋势的是一根粗的黄颜色的线,表示大盘趋势的是一根粗的紫红的线.我们规定,只有当代表股价的黄颜色的线向上穿越了代表大盘的线,才能说明个股的短线攻击强度已经具备向上攻击的能量。而市场上能推动股价上涨也只有庄家才 能做到,个股趋势一旦强于大盘,则表示控盘庄家操作目标股票意念明显,如果大盘能配合,这类股票就是引导大盘往上的龙头。{麒麟趋势}
个股上线:=Ema(EMA(close,30),7);
大盘上线:=Ema(EMA(INDEXC,49),7);
个股趋势:close/个股上线*100,coloryellow,linethick2;
个股风险:EMA(个股趋势,20),colorred;
大盘趋势:INDEXC/大盘上线*100,colorff00ff,linethick2;
大盘风险:EMA(大盘趋势,27),color00ff00;
《麒麟短线王》之“麒麟趋势”原码
n:=6;
个股趋势:MA(c,1)/MA(ref(c,18),18)*100,linethick2;
个股风险:ma(forcast(个股趋势,20),n);
大盘趋势:ema(INDEXC,1)/MA(ref(INDEXC,18),18)*100,linethick2,color009900;
大盘风险:ma(forcast(大盘趋势,20),n),colorred;

              麒麟天地
        麒麟天地能准确的判断一只股票的头部或者底部的出现,特别在股票在暴跌或者暴涨之中,麒麟天地更能准确的抓住目标的一个阶段性头部或者底。
                庄家进退
           庄家进退是监控市场上庄家资金进退的过程,所谓的庄家进退是针对某一时间段而决定的,红色的代表进场资金,绿色的代表退场资金,当股价处于相对低位的时候 进场只有是主力庄家,投资者是不会在一个不知底在何方的时候买进任何一只股票,这时候的退场资金则是庄家进场资金;而当股价涨到一定高位的时候很多投资都 会想到目标股票还能涨多少,从而盲目追进目标股票,这时候的退场资金就是庄家退场。

二、公式源码

麒 麟 短 线 王(全套指标)源码
   1.{搏杀持股}
CG:ma(C,17),colorffcc66;
FL:hhv(CG,2);
FS:if(CGSTICKLINE(close>=open,open,close,5,1),colorred;
STICKLINE(open>close,close,open,5,0 ),color00ff00;
STICKLINE(close>=open,close,HIGH,0.5 ,1 ),colorred;
STICKLINE(close>=open,open,low,0.5 ,1 ),colorred;
STICKLINE(open>close,close,low,0.5 ,0 ),color00ff00;
STICKLINE(open>close,open,HIGH,0.5 ,0 ),color00ff00;
-------------------------------
2.{搏杀生命}
amv0:=vol*(o+c)/2;
BS:sum(amv0,88)/sum(vol,88),colorff00ff,linethick2;
STICKLINE(close>=open,open,close,5,1),colorred;
STICKLINE(open>close,close,open,5,0 ),color00ff00;
STICKLINE(close>=open,close,HIGH,0.5 ,1 ),colorred;
STICKLINE(close>=open,open,low,0.5 ,1 ),colorred;
STICKLINE(open>close,close,low,0.5 ,0 ),color00ff00;
STICKLINE(open>close,open,HIGH,0.5 ,0 ),color00ff00;
-------------------------------
3.{操盘频率}
操盘趋势:MA(C,3),colorff00ff,linethick2;
持仓线:MA(H,21),coloryellow;
空仓线:MA(L,21),color00ff00;
--------------------------------
4.{短线快枪}
VAR1:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
快枪:EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10,COLORRED;
-------------------------
5.{买卖天机}
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:vol,pointdot;
主动买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE主动卖盘:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSEstickline(VOL>0,vol,0,4,1),colorwhite;
stickline(主动买盘>0,0,主动买盘,4,0),colorred;
stickline(主动卖盘<0,0,主动卖盘,4,0),color00ff00;
---------------------------
6.{派发区域}
VAR1:=HHV(HIGH,146);
派发高点:IF(var1>LLV(LOW,293)*1.45 AND VAR1>LOW*1.3,VAR1,0);
派发区域:IF(var1>LLV(LOW,293)*1.45 AND VAR1>LOW*1.3,VAR1*0.82,0);
庄家底仓LV(LOW,146);
庄家建仓LV(LOW,146)*1.2;
-------------------------
7.{麒麟均线(主图)}
amv0:=vol*(o+c)/2;
博杀生命线:sum(amv0,88)/sum(vol,88),colorff00ff,linethick2;
CG:ma(C,17),colorffcc66,linethick2;
FL:=hhv(CG,2);
博杀持股线:hhv(CG,2),color00ff00;
FS:CG-(FL-CG),coloryellow,linethick2;
-------------------------------
8.{麒麟趋势}
个股上线:=Ema(EMA(close,30),7);
大盘上线:=Ema(EMA(INDEXC,49),7);
个股趋势:close/个股上线*100,coloryellow,linethick2;
个股风险:EMA(个股趋势,20),colorred;
大盘趋势:INDEXC/大盘上线*100,colorff00ff,linethick2;
大盘风险:EMA(大盘趋势,27),color00ff00;
------------------------
9.{资金趋势}
a:=vol*close;
b:=sum(a,1)/sum(vol,1);
b1:=emA(b,17);
资金b-b1)*100/b,colorred;
强弱线:0,colorffcc66;10. {麒麟刀}
趋势:MA((OPEN+CLOSE)/2,1),COLORFF80FF,LINETHICK2;{PRECIS2;}
短线:MA((OPEN+CLOSE)/2,5),COLORCYAN;
平衡:MA((OPEN+CLOSE)/2,21),COLORYELLOW;
中期:MA((OPEN+CLOSE)/2,34),COLORRED;
长期:MA((OPEN+CLOSE)/2,60),COLORBLUE; 三/  麒 麟 短 线 王(全套指标)源码 大智慧    {搏杀持股}
CG:ma(C,17),colorffcc66;
FL:hhv(CG,2);
FS:if(CGSTICKLINE(close>=open,open,close,5,1),colorred;
STICKLINE(open>close,close,open,5,0 ),color00ff00;
STICKLINE(close>=open,close,HIGH,0.5 ,1 ),colorred;
STICKLINE(close>=open,open,low,0.5 ,1 ),colorred;
STICKLINE(open>close,close,low,0.5 ,0 ),color00ff00;
STICKLINE(open>close,open,HIGH,0.5 ,0 ),color00ff00;

-------------------------------

{搏杀生命}
amv0:=vol*(o+c)/2;
BS:sum(amv0,88)/sum(vol,88),colorff00ff,linethick2;

STICKLINE(close>=open,open,close,5,1),colorred;
STICKLINE(open>close,close,open,5,0 ),color00ff00;
STICKLINE(close>=open,close,HIGH,0.5 ,1 ),colorred;
STICKLINE(close>=open,open,low,0.5 ,1 ),colorred;
STICKLINE(open>close,close,low,0.5 ,0 ),color00ff00;
STICKLINE(open>close,open,HIGH,0.5 ,0 ),color00ff00;

-------------------------------

{操盘频率}
操盘趋势:MA(C,3),colorff00ff,linethick2;
持仓线:MA(H,21),coloryellow;
空仓线:MA(L,21),color00ff00;

--------------------------------

{短线快枪}
VAR1:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
快枪:EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10,COLORRED;

-------------------------

{买卖天机}
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:vol,pointdot;
主动买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE主动卖盘:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSEstickline(VOL>0,vol,0,4,1),colorwhite;
stickline(主动买盘>0,0,主动买盘,4,0),colorred;
stickline(主动卖盘<0,0,主动卖盘,4,0),color00ff00;

---------------------------

{派发区域}
VAR1:=HHV(HIGH,146);
派发高点:IF(var1>LLV(LOW,293)*1.45 AND VAR1>LOW*1.3,VAR1,0);
派发区域:IF(var1>LLV(LOW,293)*1.45 AND VAR1>LOW*1.3,VAR1*0.82,0);
庄家底仓:LLV(LOW,146);
庄家建仓:LLV(LOW,146)*1.2;

-------------------------

{麒麟均线(主图)}
amv0:=vol*(o+c)/2;
博杀生命线:sum(amv0,88)/sum(vol,88),colorff00ff,linethick2;
CG:ma(C,17),colorffcc66,linethick2;
FL:=hhv(CG,2);
博杀持股线:hhv(CG,2),color00ff00;
FS:CG-(FL-CG),coloryellow,linethick2;

-------------------------------

{麒麟趋势}
个股上线:=Ema(EMA(close,30),7);
大盘上线:=Ema(EMA(INDEXC,49),7);
个股趋势:close/个股上线*100,coloryellow,linethick2;
个股风险:EMA(个股趋势,20),colorred;
大盘趋势:INDEXC/大盘上线*100,colorff00ff,linethick2;
大盘风险:EMA(大盘趋势,27),color00ff00;

------------------------

{资金趋势}
a:=vol*close;
b:=sum(a,1)/sum(vol,1);
b1:=emA(b,17);
资金:(b-b1)*100/b,colorred;
强弱线:0,colorffcc66;